Login    Register
  • Author

Strange Sport SX/SafeFly GPS accuracy problem

Postby yoloflyer » Sat Dec 23, 2017 6:18 am

I'm copying most of this from a post I made on the Vans Airforce forum in the hopes of catching the eye of someone who may look here but not peruse that forum...

Avionics/gizmo background:

GRT Sport SX EFIS, 7 years old, but latest software, with internal GPS (was an option when I bought the unit).

7 year old Trutrak autopilot.

Garmin Aera 510 GPS in airgizmos mount.

Newly installed GRT SafeFly GPS/uAvionix Echo UAT combo, connected to the Sport SX- replacing a (gasp) NavWorx EXP box.

When I built the panel, I wired it such that either the Sport SX or the Aera could feed the Trutrak autopilot a flight plan, via a toggle switch on the panel.

Originally I also fed an RS232 line from the Aera to the Sport SX so it could serve as a second GPS in the event (however unlikely) of a failure of the internal GPS.

Since the Sport SX can only support 2 GPS devices, when I installed the SafeFy GPS I disconnected the RS232 input to the Sport SX from the Aera.

Today I made a short cross country flight and engaged the autopilot for the first time since installing the SafeFly/Echo combo, and observed some very strange (to me) behaviors, which I can hopefully summarize here.

Engaging the autopilot to track a heading with the GPS input set to Aera, everything worked as expected. It turned out the winds at my altitude were negligible, so track and heading were about the same. The track displayed on the autopilot, EFIS and Aera were all the same within a degree. I tried switching the autopilot input source to EFIS; with the internal GPS (labeled as GPS 1) selected, all continued to be well. But when I tried selecting the SafeFly GPS (AKA GPS 2) as the input source, the autopilot suddenly displayed a heading about 14 degrees to the right of the heading previously selected and turned the plane about 14 degrees left to compensate. Switching back to the internal GPS returned the aircraft to the original (correct) heading. Weird.

The GRT display unit maintenance page in the setup menu has a GPS status page. Checking that showed that both the original internal GPS unit and the Safefly GPS were indicating a GPS track about 14 degrees to the right of the heading displayed on the Aera and everything else. I checked ForeFlight on my iPhone, it agreed with the Aera, and even my humble magnetic compass showed the same heading. If I selected EFIS as the input source to the autopilot and selected the SafeFly GPS as the NAV option on the EFIS, the plane turned left 14 degrees. Yet, despite the internal status page indication to the contrary, selecting the old internal GPS as the NAV source returned the plane to the original correct heading. During all of this, the heading and track indications on the EFIS PFD and map pages indicated the correct (according to Aera, compass and iPhone) headings, despite the incorrect readings shown on the status page.

So for some reason both EFIS internal and external (SafeFly) GPS units appear to be reporting an erroneous 14 degrees to the right heading, but only the SafeFly GPS causes the autopilot to veer off course, and both units seem to report the correct heading information to the PFD display.

I plan to call GRT support about this, but given the holidays I expect it will be awhile before I hear back. Meanwhile, to anyone reading, does that make sense? Happy to add clarification. This is the first I've ever heard of a GPS reading so wildly erroneously.
Posts: 15
Joined: Sat Aug 24, 2013 4:41 am

Re: Strange Sport SX/SafeFly GPS accuracy problem

Postby yoloflyer » Sun Dec 24, 2017 5:59 am

Answering part of my own question, it appears that for some reason heading data from the SafeFly GPS is not being converted to magnetic from native true by the Sport SX. The magnetic variation here near the SF Bay area is about 14º, same as the error I'm seeing. Why is the internal GPS data being converted but not the output from the SafeFly GPS?
Posts: 15
Joined: Sat Aug 24, 2013 4:41 am

Re: Strange Sport SX/SafeFly GPS accuracy problem

Postby yoloflyer » Sun Dec 24, 2017 5:32 pm

Having slept on it, I'm now almost certain that the issue I'm having is the heading data from the SafeFly is not being converted to magnetic in the Sport SX, whereas the internal GPS data is. I can't find a setting to change that.

My Sport SX is a legacy unit (pre adaptive AHRS), serial number 775, with upgraded processor so I have 5 serial ports. Running rev 14.00 software. I have the RS232 lines from the SafeFly connected to serial port 5, and ADS-B connected to serial port 4 in. I still have RS232 out from my Aera connected to serial port 1 in, though it's now set to OFF.
Posts: 15
Joined: Sat Aug 24, 2013 4:41 am

Re: Strange Sport SX/SafeFly GPS accuracy problem

Postby GRT_Jeff » Thu Jan 04, 2018 4:25 am

The "Track" on the GPS Status page is always true (not magnetic). The track displayed on other pages like the PFD and map is magnetic. The Safe-Fly GPS does not compute magnetic variation so the display (SX) has to do it. This only takes a few seconds and it should show up as "Mag Var" on the GPS Status page. The older Internal GPS computes it. There's no setting for this. The display computation happens automatically when any GPS doesn't provide it. I just connected a Safe-Fly GPS to a Sport SX and the magnetic conversion appears to be working properly.

The heading (HDG) on the PFD comes from the magnetometer.

Make sure your "GPS from ADS-B Receiver" is set to "No / Not Independent". If you have that set to something else it might interfere but I don't think it would completely prevent the magnetic variation from computing correctly.
Posts: 630
Joined: Tue Dec 11, 2012 12:11 am


Postby yoloflyer » Thu Jan 11, 2018 5:45 am

Per Jeff, via email, in case anyone else stumbles on this:

"If you have an NMEA0183 GPS input and Autopilot NMEA0183 output, the EFIS takes a short cut and passes the GPS data directly from the GPS to the autopilot. In this case, the Safe-Fly doesn't compute magnetic variation so that passes through as blank. You can fix that by changing the SET MENU, Display Unit Maintenance, "APGPS NMEA0183 Passthru" setting to Off."

I did that. Internal GPS is GPS 1, SafeFly is GPS 2. TruTrak no longer cares which one is driving it, it all looks and behaves the same and all displays indicate correct magnetic heading. I can now get on with 2018...
Posts: 15
Joined: Sat Aug 24, 2013 4:41 am

Return to Sport SX

Who is online

Users browsing this forum: No registered users and 4 guests